Jimmy Joy forum

Where is my subscription?

#1

My subscription has disappeared from My Account page.

My last three orders appear, my address but the options related to my subscription have disappeared. What has happened?

#2

Same problem for me.

1 Like
#3

Hi! @karel @MaartenBr @Tim

#4

@monjope @dClauzel Hi Guys! Thanks for letting us know about this. I’ll look into it and get back to you as fast as I can!

Talk soon

#5

@monjope @dClauzel Hi Guys, I took a look at the customer portal and it seems that you can view your subscription via a kind of pop-up which takes a couple of seconds to load. Perhaps it’s blocked by adblocker or something of the likes. Could you please let me know if this worked for you?

We’re working on changing the subscription management system to make it easier and more clear, but I’m afraid it’s not without it’s challanges :wink:

Talk soon!

#6

I have tested with two browsers. Adblock disabled in both, cookies and cache deleted. A pop-up opens, but it’s about the time token.

#7

Thanks for the screenshot Monjope.

The ‘pop up’ should appear where it says ‘order history’. Perhaps give it more than a couple of seconds and try refreshing as well. I’m sure you’re trying everything but we ran a test yesterday and sometimes it seemed to do the trick. In any case, we had a meeting about the interface and are going to update it again soon, so it should be running smoothly again shortly. In the meantime you can email us for a special link that will allow you to edit/manage your subscriptions with a little bit of a workaround. So sorry for the inconvenience and let us know if there’s anything else we can do for now.

#8

Thanks for the help, but it still does not appear.

I have tried with another browser, with another OS, with my smartphone and tablet, I have refreshed and waited and nothing happens.

Is it possible that our subscription has been deleted by mistake from the database and therefore does not appear?

Edit:

Ok, problem solved.

In the confirmation email of my subscription, there is a link to “Manage Subscription”. From there I can access without problems.

Thanks for the help. I hope this also works for @dClauzel

1 Like
#9

Yes, it does. Thanks.

2 Likes
#10

Glad you figured it out @monjope! Sorry for the inconvenience, we’ll have it back up and running smoothly again soon :slight_smile:

1 Like